Uploaded image for project: 'OpenShift Virtualization'
  1. OpenShift Virtualization
  2. CNV-29281

[2211057] Templates Catalog shows Default Templates incorrectly

XMLWordPrintable

    • Medium

      Description of problem:
      Templates Catalog page does not show default templates correctly,
      it shows some extra template(s) that should not be there, if the user creates some templates.

      Version-Release number of selected component (if applicable):
      4.13

      How reproducible:
      always

      Steps to Reproduce:
      1. Access Virtualization > Templates
      2. Create a very simple template named "example" from the default yaml
      3. Filter templates list to show only "Default Templates"
      4. Now compare the result with Templates Catalog page, after clicking on "Default Templates"

      Actual results:
      The template "example" is present among "Default Templates" in Templates Catalog
      page, which is wrong. It is not a default template. Also the number of items shows
      there is one extra template, comparing to the list of "Default Templates" in Templates list,
      which shows the templates correctly.

      Expected results:
      Only default templates are present in the Templates Catalog page, when displaying
      "Default Templates".

      Additional info:
      Note that a template created from a "default" yaml is NOT a default template.
      The "default templates" are only Red Hat ones (a.k.a templates present in the Templates list
      from the "beginning" of using OpenShift Virtualization, by default, not those that are
      created by the user later).

      Choose "All Projects" to correctly see all the templates, to correctly compare the number of templates in both pages.

            hstastna@redhat.com Hilda Stastna
            hstastna@redhat.com Hilda Stastna
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Created:
              Updated:
              Resolved: