Uploaded image for project: 'Application Server 7'
  1. Application Server 7
  2. AS7-5837

CLI Script Support - Existing host with name containing _ not found

    Details

    • Steps to Reproduce:
      Hide

      I have host controllers named:
      domain, station3_host1, station3_host2

      I can get to them in CLI shell using /host=station3_host1 for example

      using groovy:
      when I issue a cli.cmd("cd /host=domain") that works but if I put the other two in as the host name - it complains that it cannot find the host.

      a ("cd host") followed by an ("ls") shows them spelled exactly as they exist

      Show
      I have host controllers named: domain, station3_host1, station3_host2 I can get to them in CLI shell using /host=station3_host1 for example using groovy: when I issue a cli.cmd("cd /host=domain") that works but if I put the other two in as the host name - it complains that it cannot find the host. a ("cd host") followed by an ("ls") shows them spelled exactly as they exist

      Description

      I cannot access a host with the CLI object from scriptsupport package when the host name contains an underscore ("_"). Regular names work fine.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                aloubyansky Oleksiy Lubyanskyy
                Reporter:
                jimrigsbee Jim Rigsbee
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: