-
Feature Request
-
Resolution: Done
-
Major
-
1.0.0.Alpha4
-
None
For better consistent naming, we should rename the API annotations:
- @Run(RunModeType) = @RunAsClient
- InContainer is extracted from @Deployment(testable) and only possible to override with AS_CLIENT
- @Expected = @ShouldThrowException
- @Target = @TargetsContainer("x")
- Clearify meaning
- @DeploymentTarget = @OperateOnDeployment
- Clearify that this test will operate within the context of the @Deployment
public class TestClass { @Deployment(name = "dep", testable=false) @ShouldThrowException(Exception.class) @TargetsContainer("x") public JavaArchive create() {} container x{ deployment dep{ @Test @RunAsClient @OperateOnDeployment("dep") public void shouldBe() {} container x{ @Test @OperateOnContainer("x") public void shouldBe() {} }
- is related to
-
ARQ-390 Add annotation @OperateOnContainer
- Open