Uploaded image for project: 'Arquillian'
  1. Arquillian
  2. ARQ-1568

Droidium fails if emulator is about to start and there is not API level 10 and apiLevel is not in config

    Details

      Description

      Given:

      1. Already existing emulator with API level != 10 available
      2. Emulator is not started prior to tests
      3. API level 10 is not installed locally on developers machine
      4. apiLevel configuration option is not set in arquillian.xml

      When:

      I want to start emulator with the environment above

      Then:

      Droidium does not fail.

      The reason why it fails is that in case AVD of such name in avdName property does not exist, Droidium tries to create AVD dynamically and it is deleted after tests. Default API level is 10 so when apiLevel is not specified, it attempts to create emulator with that API level, but it might not be present on the system - so it fails.

      The workaround could be to filter all available API level and choose the lowest one as the default one and not API level 10 which is set statically.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  smikloso Stefan Miklosovic
                  Reporter:
                  smikloso Stefan Miklosovic
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: