Uploaded image for project: 'Agent-based deployment for OpenShift Installer'
  1. Agent-based deployment for OpenShift Installer
  2. AGENT-545

Use vSphere credentials from install-config

XMLWordPrintable

    • Use vSphere credentials from install-config in Agent
    • 20
    • False
    • Hide

      None

      Show
      None
    • False
    • Green
    • In Progress
    • OCPSTRAT-701 - Use vSphere credentials from install-config in Agent
    • OCPSTRAT-701Use vSphere credentials from install-config in Agent
    • 0% To Do, 7% In Progress, 93% Done
    • Hide

      2/19/2024 - Status: Green

      Bug fix for OCPBUGS-25718 merged and backport onto release-4.15 branch also merged OCPBUGS-29485

      2/06/2024 - Status: Yellow

      Bug fix for OCPBUGS-25718 is under review.

      1/29/2024 - Status: Red

      Continuing to work on bug fix for OCPBUGS-25718. Expect to post bug fix for review by end of this week.

      1/19/2024 - Status: Red

      Additional investigation into OCPBUGS-25718 and found root cause. New solution proposed and vetted with cloud team. Working on bug fix.

      1/11/2024 - Status: Red

      Although vsphere credentials are installed, the CSI operator cannot finish installing due to a bug described in OCPBUGS-25718. Currently triaging the bug, do not know the root cause.

      11/10/2023 - Status: Green

      assisted-service PRs merged with help from Adrien Gentil. CI job and dev-scripts support PRs are in review. 

      11/03/2023 - Status: Yellow

      assisted-service PRs are blocked by CI failures, and they appear to be infrastructure failures. Consulting with assisted-service team. Submitted PR to add vSphere credential support in dev-scripts which will allow us to do partial testing for vSphere platform in CI using libvirt and not actual vSphere hosts. Next step is to add CI job.

      10/27/2023 - Status: Green

      PRs to fix json issues in assisted-service submitted and under going review. Remaining task is adding CI test and completing dev-scripts support for testing vSphere deployments using libvirt.

      10/13/2023 - Status: Green
      PRs to (1) not ignore vSphere credentials and (2) add vSphere credentials to install-config overrides have been submitted for review.

      Show
      2/19/2024 - Status: Green Bug fix for OCPBUGS-25718 merged and backport onto release-4.15 branch also merged OCPBUGS-29485 2/06/2024 - Status: Yellow Bug fix for OCPBUGS-25718 is under review. 1/29/2024 - Status: Red Continuing to work on bug fix for OCPBUGS-25718 . Expect to post bug fix for review by end of this week. 1/19/2024 - Status: Red Additional investigation into OCPBUGS-25718 and found root cause. New solution proposed and vetted with cloud team. Working on bug fix. 1/11/2024 - Status: Red Although vsphere credentials are installed, the CSI operator cannot finish installing due to a bug described in OCPBUGS-25718 . Currently triaging the bug, do not know the root cause. 11/10/2023 - Status: Green assisted-service PRs merged with help from Adrien Gentil. CI job and dev-scripts support PRs are in review.  11/03/2023 - Status: Yellow assisted-service PRs are blocked by CI failures, and they appear to be infrastructure failures. Consulting with assisted-service team. Submitted PR to add vSphere credential support in dev-scripts which will allow us to do partial testing for vSphere platform in CI using libvirt and not actual vSphere hosts. Next step is to add CI job. 10/27/2023 - Status: Green PRs to fix json issues in assisted-service submitted and under going review. Remaining task is adding CI test and completing dev-scripts support for testing vSphere deployments using libvirt. 10/13/2023 - Status: Green PRs to (1) not ignore vSphere credentials and (2) add vSphere credentials to install-config overrides have been submitted for review.

      Stop ignoring any (optional) vSphere credential values provided in the install-config, and pass them instead to the cluster. This allows users to configure the credentials at day 1 if they want to, though it should remain optional. It also means that an install-config usable for IPI (where the credentials are required) should result in an equivalent cluster when the agent installer is used.

      Currently there are warning messages logged about these values being ignored when provided. These warnings should be removed when the values are no longer ignored.

      In the absence of direct API support for this in assisted, we should be able to use install-config overrides (which the agent installer is already able to make use of internally).

            rwsu1@redhat.com Richard Su
            zabitter Zane Bitter
            Manoj Hans Manoj Hans
            Ramon Acedo Ramon Acedo
            Votes:
            5 Vote for this issue
            Watchers:
            10 Start watching this issue

              Created:
              Updated:
              Resolved: