iOS: API: AGStore's remove takes an id, should take an object
Like on the AGPipe, we should update this API...
ios: API: rename 'getter' for 'modules'
Inside of the following classes we have a getter, to get an actual object by its name:
However, this is not best practice. Usually a method that starts with 'get' deliver values by reference
See NSColor (https://developer.apple.com/library/mac/#documentation/Cocoa/Reference/ApplicationKit/Classes/NSColor_Class/Reference/Reference.html)
- (void)getComponents:(CGFloat *)components
Instead of, for instance:
- (id<AGAuthenticationModule>)get:(NSString *)moduleName
we can have something LIKE this:
- (id<AGAuthenticationModule>)loadModuleNamed:(NSString *)moduleName
Current 'get' methods:
ios: AGPipeline: rename init: and pipeline:
rename the -init: (not the -init) to something like:
-initWithBaseURL:(NSURL *)baseURL (instead of -init
same for +pipeline: (+pipelineWithBaseURL:(NSURL *)baseURL)
ios: rename AGRestAdapter to AGRESTAdapter
Since REST is an less or more offical term. Perhaps we should name it AGRESTAdapter.
ios: AGPipe: Change the URL property
Let's change the url property to be URL:
@property (nonatomic, readonly) NSString *URL
Maybe...... it should be really of the NSURL type....
ios: pipe: overhaul the remove method
The remove function seems a bit odd since it takes the 'id' value:
Using CoreData as some precedence, one would delete the object.
iOS: overhaul config API
For the config object we currently "set" values like:
would be better.
Ideally the options would be regular properties:
config.name = @""