Uploaded image for project: 'WildFly WIP'
  1. WildFly WIP
  2. WFWIP-84

[Artemis 2.x upgrade] MDB deployed on EAP 7.2.0 with new Artemis cannot connect to queue deployed on EAP6

    XMLWordPrintable

    Details

      Description

      I'm not able to connect with MDB deployed on WF14/EAP 7.2.0 with new Artemis to destination deployed on EAP6.

      CLI for configuration EAP7:

      /socket-binding-group=standard-sockets/remote-destination-outbound-socket-binding=remote-eap6-binding:add(port=6445)
      /subsystem=messaging-activemq/server=default/remote-connector=remote-eap6-connector:add(socket-bidning=remote-eap6-binding)
      /subsystem=messaging-activemq/server=default/pooled-connection-factory=remote-eap6:add(connectors=[remote-eap6-connector], entries=["jms/remote-eap6", "java:jboss/exported/jms/remote-eap6"], protocol-manager-factory="org.apache.activemq.artemis.core.protocol.hornetq.client.HornetQClientProtocolManagerFactory)
      

      The MDB is annotated with

      @MessageDriven(activationConfig = {
              @ActivationConfigProperty(propertyName = "useJNDI", propertyValue = "false"),
              @ActivationConfigProperty(propertyName = "destinationType", propertyValue = "javax.jms.Queue"),
              @ActivationConfigProperty(propertyName = "destination", propertyValue = "InQueue"),
              @ActivationConfigProperty(propertyName = "acknowledgeMode", propertyValue = "Auto-acknowledge")
      })
      @ResourceAdapter("remote-eap6")
      

      This setup worked with EAP 7.1.x and EAP 7.2.0.Beta with older Artemis

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              martyn-taylor Martyn Taylor (Inactive)
              Reporter:
              msvehla Martin Svehla
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: