Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-9406

Upgrade ASM with Version 5.2 (unable to use Arquillian+JaCoCo with ASM 3.3.1)

    XMLWordPrintable

    Details

      Description

      Reported in GitHub https://github.com/wildfly/wildfly/issues/10531

      Arquillian Extension dependends on JaCoCo does not work on WildFLy because AS uses ASM 3.3.1 and JaCoCo uses ASM 5.2.
      The class org.jacoco.core.internal.flow.ClassProbesVisitor extends ASM class org.objectweb.asm.ClassVisitor. The problem is that ClassVisitor is interface in ASM 3.3.1.

      Please upgrade it in POM:
      https://github.com/wildfly/wildfly/blob/master/pom.xml

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              rhn-support-asoldano Alessio Soldano
              Reporter:
              tibor17 Tibor Digana (Inactive)
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: