Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-7409

BanTransitiveDependencies for Full Feature Pack module on IBM jdk

    XMLWordPrintable

Details

    • Workaround Exists
    • Hide

      run build with

      -Denforcer.skip=true
      Show
      run build with -Denforcer.skip=true

    Description

      Building wildfly-feature-pack:7.1.0.Alpha1-redhat-4 fails on IBM jdk.

      [INFO] --- maven-enforcer-plugin:1.4:enforce (ban-transitive-deps) @ wildfly-feature-pack ---
      [WARNING] Rule 0: org.apache.maven.plugins.enforcer.BanTransitiveDependencies failed with message:
      org.jboss.eap:wildfly-feature-pack:pom:7.1.0.Alpha1-redhat-4
         org.apache.cxf:cxf-rt-features-clustering:jar:3.1.6.redhat-1:compile has transitive dependencies:
            xalan:xalan:jar:2.7.1.redhat-11:compile
               xalan:serializer:jar:2.7.1.redhat-11:compile
      

      full log http://pastebin.test.redhat.com/406421

      Same worked with 7.1.0.DR2 bits (7.1.0.Alpha1-redhat-2). The issue is preventing us from running the EAP unit tests on IBM jdk - see https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-7x-as-testsuite-test-unit-rhel/37/.

      Attachments

        Issue Links

          Activity

            People

              tomazcerar Tomaž Cerar (Inactive)
              tomazcerar Tomaž Cerar (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: