Uploaded image for project: 'Tattletale'
  1. Tattletale
  2. TTALE-164

Errors in maven plugin descriptor

    Details

    • Steps to Reproduce:
      Hide

      1) Remove the plugin from your repo
      2) Install from http://repository.jboss.org/nexus/content/groups/public
      3) Build with maven 3 and i.e.:
      ...
      <plugin>
      <groupId>org.jboss.tattletale</groupId>
      <artifactId>tattletale-maven</artifactId>
      <version>1.1.1.Final</version>
      <executions>
      <execution>
      <goals>
      <goal>report</goal>
      </goals>
      </execution>
      </executions>
      <configuration>
      <source>src/main</source>
      <destination>target/tattletale</destination>
      </configuration>
      </plugin>
      ...

      Show
      1) Remove the plugin from your repo 2) Install from http://repository.jboss.org/nexus/content/groups/public 3) Build with maven 3 and i.e.: ... <plugin> <groupId>org.jboss.tattletale</groupId> <artifactId>tattletale-maven</artifactId> <version>1.1.1.Final</version> <executions> <execution> <goals> <goal>report</goal> </goals> </execution> </executions> <configuration> <source>src/main</source> <destination>target/tattletale</destination> </configuration> </plugin> ...
    • Affects:
      Compatibility/Configuration
    • Estimated Difficulty:
      Low

      Description

      The maven plugin descriptor (tattletale-maven-1.1.1.Final.jar:META-INF/maven/plugin.xml) contains the wrong tattletale version.

      [ERROR] Invalid plugin descriptor for org.jboss.tattletale:tattletale-maven:1.1.1.Final (/Users/oc/.m2/repository/org/jboss/tattletale/tattletale-maven/1.1.1.Final/tattletale-maven-1.1.1.Final.jar), Plugin's descriptor contains the wrong version: 1.1.0.Final -> [Help 1]
      org.apache.maven.plugin.InvalidPluginDescriptorException: Invalid plugin descriptor for org.jboss.tattletale:tattletale-maven:1.1.1.Final (/Users/oc/.m2/repository/org/jboss/tattletale/tattletale-maven/1.1.1.Final/tattletale-maven-1.1.1.Final.jar), Plugin's descriptor contains the wrong version: 1.1.0.Final

      Fix:

      — plugin.xml.orig 2010-12-03 16:39:58.000000000 +0100
      +++ plugin.xml 2010-12-03 16:39:20.000000000 +0100
      @@ -2,7 +2,7 @@
      <description></description>
      <groupId>org.jboss.tattletale</groupId>
      <artifactId>tattletale-maven</artifactId>

      • <version>1.1.0.Final</version>
        + <version>1.1.1.Final</version>
        <goalPrefix>tattletale</goalPrefix>
        <isolatedRealm>false</isolatedRealm>
        <inheritedByDefault>true</inheritedByDefault>
        @@ -112,6 +112,6 @@
        <dependencies>
        <groupId>org.jboss.tattletale</groupId>
        <artifactId>tattletale</artifactId>
      • <version>1.1.0.Final</version>
        + <version>1.1.1.Final</version>
        </dependencies>
        </plugin>

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                jesper.pedersen Jesper Pedersen
                Reporter:
                olecr Ole Christian Rynning
              • Votes:
                1 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1 minute
                  1m
                  Remaining:
                  Remaining Estimate - 1 minute
                  1m
                  Logged:
                  Time Spent - Not Specified
                  Not Specified