Uploaded image for project: 'TorqueBox'
  1. TorqueBox
  2. TORQUE-975

New Rake 10.0.2 causes issues with torquebox-rake-support dependency

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.2.0
    • Component/s: None
    • Labels:
      None

      Description

      Since Rake decided to skip from 0.9.5 to 10.0.2 our dependency on Rake < 1.0.0 in torquebox-rake-support causes problems when a user adds torquebox to an existing application that uses Bundler in cases where previously the application chose Rake 10.0.x and now a bundle update instead of a simple bundle install must be done to fix the Rake dependency to 0.9.x.

      There's no reason we shouldn't work with the newer Rake so just loosen the version requirement.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                benbrowning Ben Browning
                Reporter:
                benbrowning Ben Browning
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: