Uploaded image for project: 'TorqueBox'
  1. TorqueBox
  2. TORQUE-780

Newrelic Doesn't work on 2.0.0 or 2.0.1

    Details

    • Steps to Reproduce:
      Hide

      Install 2.0.1 with Rails 3.1 - try and use NewRelic

      Show
      Install 2.0.1 with Rails 3.1 - try and use NewRelic

      Description

      New Relic gem fails to load properly under Torquebox 2.0.1 and 2.0.0 - it loads fine in 2.0.0.cr1

      Firstly the gem looks for the config file on root /config instead of RAILS_ROOT/config. With a hack and symlinking to /config/newrelic.yml - the gem loads and you get a green light on NewRelic. However no data gets exchanged. Production.log was getting updated - everything elese okay - just no data flowing to NewRelic

      Tried a suggested fix of setting ENV['NPRCONFIG'] = "/path/to/my/app/config/newrelic.yml" this did solve the path issue but not the loading.

      After speaking to NewRelic - they told me that Torquebox had an issue parsing YAML - which I couldn't find (checked on IRC too) however. They suggested loading the gem manually - which still did not work.

      I have tried this in 2.0.1 and 2.0.0 both with the same issue... when i rolled back to 2.0.0.cr1 it was fine - I was using the correct gems each time, and rebuilt Jruby each time to check.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                tcrawley Toby Crawley
                Reporter:
                charliedavi Charlie Davies
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: