Uploaded image for project: 'TorqueBox'
  1. TorqueBox
  2. TORQUE-774

HornetQ not starting (Torquebox 2.0.1 on ubuntu 11.10)

    Details

    • Steps to Reproduce:
      Hide

      Just one step on my machine with the above environment:

      $ torquebox run

      Show
      Just one step on my machine with the above environment: $ torquebox run
    • Workaround:
      Workaround Exists
    • Workaround Description:
      Hide

      The workaround for now is to manually configure Hornet to use NIO by editing $JBOSS_HOME/standalone/configuration/standalone.xml and adding

      <journal-type>NIO</journal-type>

      before <journal-file-size> (around line 257)

      Show
      The workaround for now is to manually configure Hornet to use NIO by editing $JBOSS_HOME/standalone/configuration/standalone.xml and adding <journal-type>NIO</journal-type> before <journal-file-size> (around line 257)

      Description

      HornetQ fails to start and complains of a permission error.

      I have tried with both libaio1 installed and not installed, but both produce the same results.

      Here's a gist of the console output, with the ambiguous error from HornetQ:
      https://gist.github.com/2406315

      And here, the gist from server.log with TRACE logging for HornetQ:
      https://gist.github.com/2407158

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                dcolebatch David Colebatch
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: