Uploaded image for project: 'TorqueBox'
  1. TorqueBox
  2. TORQUE-726

by default the Gemfile does not specify the version of torquebox, which cause bundle to bring in 1.1.1 => causes errors at runtime

This issue belongs to an archived project. You can view it, but you can't modify it. Learn more

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Done
    • 2.0.0.CR1
    • 2.0.0
    • Rails
    • None
    • Workaround Exists
    • Hide

      before running bundle; open up Gemfile and add the version to all the torquebox gems (currently 2.0.0.cr1). then when bundle runs; it only brings in all the 2.0.0.cr1 gems and there are no errors at runtime

      Show
      before running bundle; open up Gemfile and add the version to all the torquebox gems (currently 2.0.0.cr1). then when bundle runs; it only brings in all the 2.0.0.cr1 gems and there are no errors at runtime

    Description

      by default torquebox rails <my app> creates a Gemfile with torquebox without a version. when bundle install is run, bundle mixes both 2.0.0.cr1 and 1.1.1 torquebox gems. therefore after deployment, torquebox run cause errors

      Attachments

        Activity

          People

            lball1@redhat.com Lance Ball
            mpurdy1973_jira Matthew Purdy
            Archiver:
            samahaja@redhat.com Sagar Mahajan

            Dates

              Created:
              Updated:
              Resolved:
              Archived: