Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-78

NPE when executing JAR file after mvn package with Alpha 3

    Details

    • Type: Story
    • Status: Closed (View Workflow)
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.0.0.Alpha6
    • Component/s: None
    • Labels:
      None

      Description

      Hi,

      I'm getting this null pointer exception error when I try to execute the packaged JAR:

      Exception in thread "main" java.lang.NullPointerException
      	at org.wildfly.swarm.bootstrap.modules.BootstrapModuleFinder.gatherJarsFromJar(BootstrapModuleFinder.java:58)
      	at org.wildfly.swarm.bootstrap.modules.BootstrapModuleFinder.findModule(BootstrapModuleFinder.java:29)
      	at org.jboss.modules.ModuleLoader.findModule(ModuleLoader.java:452)
      	at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:355)
      	at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:302)
      	at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:234)
      	at org.wildfly.swarm.bootstrap.Main.main(Main.java:37)
      

      But `mvn wildfly-swarm:run`` works fine. This is my pom.xml

      The _bootstrap directory of the -swarm.jar file only contains api-0.0.1.jar

      Thanks

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                neich neich neich (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: