Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-25

Set maven prerequisites in plugin

    Details

    • Type: Story
    • Status: Closed (View Workflow)
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.0.0.Alpha6
    • Component/s: None
    • Labels:
      None

      Description

      If wildfly-swarm-plugin requires a minimum Maven version, it should define a Maven prerequisite in its POM to provide a clear error message to the user, e.g.

      <prerequisites>
      <maven>3.1.0</maven>
      </prerequisites>

      According to the README, Maven 3.2 is required, but 3.1.0 works for me. Maven 3.0.5 does fail with

      Caused by: java.lang.ClassNotFoundException: org.eclipse.aether.RepositorySystemSession

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                hwellmann Harald Wellmann
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: