Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-2464

update to latest SmallRye releases (except Config, which should be downgraded to 1.3.6)

    Details

      Description

      SmallRye moved back to the common versioning convention, and released new versions. We should update to those new versions. At the same time, we should probably downgrade SmallRye Config to 1.3.6, which is the last version which is still compliant with MP Config (the subsequent releases have some TCK exclusions for empty string handling, which is an ongoing discussion on the spec side). In 2.5.0.Final, we tried to update SmallRye Config to 1.3-1.0.0, but due to THORN-2459, SmallRye Config 1.3.4 is always used at runtime, so this won't really be a downgrade for users running released versions.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                lthon Ladislav Thon
                Reporter:
                lthon Ladislav Thon
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: