Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-2096

make sure all Config APIs depend on the same (latest) version of Config API Runtime

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: 2.0.0.Final
    • Fix Version/s: 2.1.0.Final
    • Component/s: config-api
    • Labels:
      None
    • Story Points:
      10

      Description

      We have these Config APIs:

      All of them must agree on the Config API Runtime version, otherwise THORN-2015 happens. We worked around it by managing the Config API Runtime version in the BOM, but that only worked when we had everything under org.wildfly.swarm. Now that we have most of it under io.thorntail and some remnants under org.wildfly.swarm, it's even worse.

      I'm explicitly marking this as a blocker as we IMHO absolutely need to solve this in 2.1.0.Final.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                lthon Ladislav Thon
              • Votes:
                4 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: