Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-150

Dependency version mismatch from config-api

    Details

    • Type: Story
    • Status: Closed (View Workflow)
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.0.0.Alpha6
    • Component/s: None
    • Labels:
      None

      Description

      I noticed that the contents of WEB-INF/lib of a generated WAR archive that is deployed to the container has a reasonable amount of dependency duplication but with different versions.

      After some digging I found that the version of wildfly-core that is part of WildFly, which wildfly-swarm uses, is more recent than the one being used directly by config-api.

      Not sure the best solution, but one option is a BOM project that is external to both wildfly-swarm and config-api that defines these versions, which they both then import

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                kenfinni Ken Finnigan
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: