Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-617

We should require a minimum version of ant for the installer

This issue belongs to an archived project. You can view it, but you can't modify it. Learn more

    XMLWordPrintable

Details

    • Task
    • Status: Open
    • Minor
    • Resolution: Unresolved
    • 0.4
    • None
    • distribution
    • None

    Description

      We should require a minimum version of ant for running the installer - it would cut down on our test matrix. dward is seeing :
      Running the installer (from the expanded target zip):
      (02:02:54 PM) errantepiphany: [echo] Unzipped SwitchYard forge plugin.
      (02:02:55 PM) errantepiphany: [echo] Installing forge plugin to /home/errantepiphany/.forge ...
      (02:02:55 PM) errantepiphany: [java] javax.xml.parsers.FactoryConfigurationError: Provider org.apache.xerces.jaxp.DocumentBuilderFactoryImpl not found
      (02:03:21 PM) errantepiphany: tcunning: java version "1.6.0_29"

      Using ant 1.7.1. We may want to require ant 1.8.1 for running the script.

      Attachments

        Activity

          People

            tcunning@redhat.com Thomas Cunningham
            tcunning@redhat.com Thomas Cunningham
            Archiver:
            ranumula@redhat.com Raju Anumula

            Dates

              Created:
              Updated:
              Archived: