Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2989

SY project sets wrong version of Camel facet when using SwitchYard lower than 2.0

    Details

    • Workaround Description:
      Hide

      Manually set the version of Camel facet to 2.17.3 or lower
      1. Select the project
      2. Right click > Properties
      3. Select Project Facets
      4. Find the Camel facet and change its version to 2.17.3 or lower
      5. Click OK

      Show
      Manually set the version of Camel facet to 2.17.3 or lower 1. Select the project 2. Right click > Properties 3. Select Project Facets 4. Find the Camel facet and change its version to 2.17.3 or lower 5. Click OK

      Description

      Once you add Camel XML component the camel facet is set to the latest Camel version which is Camel 2.18.1.redhat-000007 if you use SwitchYard version lower than 2.0.

      Note that this camel version requires Java 1.8, so if you use Java 1.7 (supported in FSW 6.0.0.GA) then you get an error. The error pops up whenever you update the maven project (Maven > Update Project...).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  bfitzpat Brian Fitzpatrick
                  Reporter:
                  apodhrad Andrej Podhradsky
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: