Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2894

Allow <beans> as a root element for CamelContext configuration

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: quickstarts
    • Labels:
      None

      Description

      While doing some testing with the latest transform-datamapper quickstart, I stumbled upon a couple of issues preventing easy use of this example within the tooling, which I will document here. Ultimately we need to update the included camel files so that they are compatible with the Fuse camel and data transformation tooling.


      As a result of our discussion, we need to support spring <beans> element as a root element for the CamelContext configuration so that the file could be opened with Fuse Camel Editor. Same for camel impl as we added CamelContext element support in SWITCHYARD-2855.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                igarashitm tomohisa igarashi
                Reporter:
                bfitzpat Brian Fitzpatrick
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: