Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2811

Switchyard quickstarts for JBoss Fuse 6.2.1 need updating to use java1.7/1.8 and the OSGi framework

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.1
    • Component/s: tooling
    • Labels:
      None
    • Affects:
      Documentation (Ref Guide, User Guide, etc.), Compatibility/Configuration

      Description

      I built the FUSE_HOME/quickstarts/switchyard/bean-service quickstart following the Readme.md file in that directory. I fired up JBDS and imported the bean-service quickstart and found several issues. The quickstart uses JavaSE-1.6 for the JRE system lib (Fuse uses either 1.7 or 1.8) and the quickstart is based on Spring not OSGi. In addition the project opens with 7 warnings:

      See attached graphics.

      The OSGi and Java 7/8 support must be fixed to use and deploy the switchyard quickstarts on JBoss Fuse. Also, if the switchyard quickstarts are to live up to their intent, the files they use should be complete and problem free. I have tried only bean-service quickstart, but I'm pretty sure there are more like it with these issues in the Fuse/quickstarts/switchyard/ directory (42 quickstarts and 11 demos).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jmurphey Jane Murphey (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: