With the changes to
SWITCHYARD-1873, validation of the binding name field for every binding was returning a lack of a name as an error. Errors prevent the user from closing the property dialog. And since the runtime defaults the binding name, this really isn't an error - it's more of a warning.
When the user creates a binding in the editor, the name is defaulted. But there are cases with existing quickstarts (such as the new camel-atom and camel-rss quickstarts) where the binding does not have a name specified. That's what raised this as an error.
So we need to make it a warning, not an error. With some text along the lines of the "X binding name should be specified"
Keith Babo Question - what should the warning be? Should we tell them it's defaulted by the runtime under the covers - i.e. "X binding name should be specified, but will be defaulted by the runtime."? Or keep this simple?