Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2011

switchyard-wildfly-deploy project has compile errors in Eclipse

    Details

      Description

      There are numerous compiler errors after importing switchyard/release/jboss-as7/wildfly/extension into Eclipse. The problems appear are caused because dependent class files are copied into the projects output folder, but these are not picked up by Eclipse. Generally, I think it would be better if we copied the source files, and then from the project directory as opposed to the maven artifact. It is likely that the release project will be built specifically for either EAP or WildFly, thus we cannot count on the fact that the EAP extension will be available in the local maven repository (we don't deploy any artifacts from release, so they won't be in central or jboss.org repos).

      The WildFly distribution requires JDK 7 to build, so we should add enforcer to prevent folks from trying to debug test failures because of an incompatible JDK.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  rcernich Rob Cernich
                  Reporter:
                  rcernich Rob Cernich
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: