Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-913

Improve warning message when HTTP/2 is requested in an unsupported environment

    Details

    • Type: Enhancement
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2017.3.2
    • Component/s: core
    • Labels:
      None
    • Sprint:
      2017-Feb-B

      Description

      Taken from the EAP list:
      "In order to use HTTP/2 in JBoss EAP, you must have the OpenSSL provider with ALPN capability from JBoss Core Services installed and configured. This is due to the fact that HTTP/2 requires a TLS stack that supports ALPN, which is not provided by the default installation of Java 8. HTTP/2 will only work with browsers that also support the HTTP/2 standard. OpenSSL usage with JBoss EAP on HP-UX is NOT supported."

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                bob.mcwhirter Bob McWhirter
                Reporter:
                gastaldi George Gastaldi
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: