Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-642

wildfly-swarm-plugin does not work when running in Gradle 3

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2016.11.0
    • Component/s: None
    • Labels:
      None
    • Sprint:
      2016.11

      Description

      If you build this example https://github.com/lordofthejars/wildfly-example/blob/master/build.gradle which uses gradle 2.14.1 you'll see that everything works as expected.

      But if you go to https://github.com/lordofthejars/wildfly-example/blob/master/gradle/wrapper/gradle-wrapper.properties#L6 and change to 3.0 and run again you'll see that an UnsupportedOperationException is thrown by wildfly-swarm-plugin.

      I think some internals has been changed in Gradle 3 regarding plugins, see that dependency-management plugin 0.5.X does not work with Gradle 3 but 0.6.0 does.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                heiko.braun Heiko Braun
                Reporter:
                asotobu Alex Soto
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: