Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2016.11.0
    • Component/s: None
    • Labels:
      None

      Description

      Scenario:

      • Added a dependency to the Booker example (io.zipkin.brave:brave-jaxrs2:3.9.1)
      • This dependency has a JAX-RS filter and expects a CDI bean to be injected
      • This bean is produced by a transitive dependency (io.zipkin.brave:brave-core:3.9.1)
      • On boot, a "dependency is not satisfied" message appears

      This can be reproduced with the following branch:
      https://github.com/jpkrohling/booker/tree/SWARM-624-Reproducer

      I tried to add them directly as dependency for the deployment (addAsLibrary("gav")), but that didn't seem to do the trick. It looks like the dependencies aren't being scanned by the Weld for possible beans.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  heiko.braun Heiko Braun
                  Reporter:
                  juraci.costa Juraci Paixão Kröhling
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: