Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-398

Plugin selects older versions of Fractions when using Auto detection

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.0.0.Beta6
    • Fix Version/s: 1.0.0.Beta7
    • Component/s: plugins
    • Labels:
      None

      Description

      When using auto detection of WildFly Swarm dependencies the plugin will correctly select which Fractions are needed, but then depending on what is there, and their respective versions, the nearest dependency selection policy of Maven can easily result in older versions of dependent Fractions being selected.

      For instance, with the `jaxrs-war` example it auto detects `swagger` and `jaxrs`. Each of those depend on `undertow`. The problem is that both `undertow` dependencies are at the same dependency depth causing the first one found to be used, which in this instance is the one inside `swagger` which is older than the one in `jaxrs`

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                kenfinni Ken Finnigan
                Reporter:
                kenfinni Ken Finnigan
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: