Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-350

Replace the word "Container" with "Swarm".

    Details

    • Type: Enhancement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: core_1.0.0.Beta4
    • Component/s: core
    • Labels:
      None

      Description

      by having our existing org.wildfly.Swarm extend the org.wildfly.swarm.container.Container, we can allow this:

      Swarm swarm = new Swarm();
      swarm.fraction(...);

      to replace

      Container container = new Container();
      container.fraction(...);

      Purely marketing fluff, but allows us to stop saying the word "container" unless we mean Docker.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                bob.mcwhirter Bob McWhirter
                Reporter:
                bob.mcwhirter Bob McWhirter
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: