The vendor scope of MP metrics contains, in the WildFly Swarm implementation, a metric called mscLoadedModules. According to fractions/microprofile/microprofile-metrics/src/main/resources/org/wildfly/swarm/microprofile/metrics/runtime/mapping.yml, the value of this metric corresponds to the LoadedModuleCount attribute of the jboss.modules:type=ModuleLoader,name=BootModuleLoader-2 MBean in JMX. From that, it's clear that this has nothing to do with MSC – it's only about JBoss Modules.
The current name is misleading. I suggest to rename to loadedJBossModules – or maybe just loadedModules, which should be unambiguous given it's in the vendor scope.