Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-1895

Make the swagger fraction reuse library versions and modules from WF parent.

    Details

    • Type: Enhancement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 2018.3.3
    • Fix Version/s: 2018.4.1
    • Component/s: core
    • Labels:
      None

      Description

      The Swagger fraction currently references libraries which are older than what gets generated for the effective POM. Instead of fighting it all the time, it would help if we can align them with the versions coming from WF parent and reuse modules that are already published by WF parent.

      I know that the Gradle plugin isn't exactly a priority for the team, but I am hoping that I can help out in that space.

      For now though, I have found that by reducing the library version conflicts, I can build a "bundled" jar file that works without issues.

      I have prepared the commit changes and I shall share it after the issue is created.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                harsha.ramesh Harsha Ramesh
                Reporter:
                harsha.ramesh Harsha Ramesh
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: