Uploaded image for project: 'Thorntail'
  1. Thorntail
  2. THORN-1381

RESTEasy Client doesn't work with Swarm 2017.6.0

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: 2017.6.0
    • Fix Version/s: 2017.6.1
    • Component/s: None
    • Labels:
      None

      Description

      The JAX-RS Client implementation provided by RESTEasy, when used together with Swarm, stopped working with Swarm 2017.6.0. Worked perfectly well with 2017.5.0. The problem is a bunch of missing dependencies, e.g. Apache HTTP components.

      I believe this is caused by some of the dependency handling refactorings that went into 2017.6.0. Here's a standalone test: https://github.com/Ladicek/swarm-tinies/tree/master/testing/jaxrs-client – the POM declares Swarm 2017.5.0, so the test passes, but changing the version makes it fail.

      This also broke all Swarm boosters – hence marking as blocker.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  heiko.braun Heiko Braun
                  Reporter:
                  lthon Ladislav Thon
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: