Uploaded image for project: 'JBoss Enterprise SOA Platform'
  1. JBoss Enterprise SOA Platform
  2. SOA-3356

In Designer, when trying to deploy the vdb after overriding a translator property, produce an error dialog indicating the translator is not found on the server

This issue belongs to an archived project. You can view it, but you can't modify it. Learn more

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Done
    • 5.2.0.ER3
    • 5.2.0.ER4
    • EDS, Tooling
    • None
    • Not Required

    Description

      Trying to override a property on the translator. Created the override (loopback-1), then changed the Translator for the source model (long.xmi) to map to the loopback-1 override. Saved the vdb. Then tried to deploy the vdb to the server and got the "VDB Not Deployed" dialog indicating the translator is missing.

      To get around the issue, manually copied the vdb from the workspace to the server and was able to verify the override worked.

      What appears to be happening is Designer is validating the vdb against a list of translators that don't include the override.

      Attachments

        Issue Links

          Activity

            People

              van.halbert Van Halbert (Inactive)
              van.halbert Van Halbert (Inactive)
              Archiver:
              ranumula@redhat.com Raju Anumula
              David Le Sage David Le Sage (Inactive)

              Dates

                Created:
                Updated:
                Resolved:
                Archived: