The default configuration qualifiers for locale and time zone are too verbose (in an attempt to be exacting). We can loosen them up a bit for readability and to make them simpler to remember.
I propose the following name changes for the qualifiers for default locale and timezone:
DefaultLocaleKeyConfig --> DefaultLocale
DefaultTimeZoneConfig --> DefaultTimeZone
The "Key" in DefaultLocale is not needed since the type String indicates that it's a key.
Here's the simplified user experience for configuring these values in XML: