Uploaded image for project: 'Forge'
  1. Forge
  2. FORGE-304

Message 'JSF2 and Metawidget currently require Partial State Saving to be disabled' is Mojarra only

    XMLWordPrintable

Details

    • Feature Request
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Done
    • 1.0.0.Alpha4
    • 1.0.0.Beta1
    • None
    • None

    Description

      Hi guys,

      Congrats on the latest release (Alpha4) of Seam Forge! When I try it, I see:

      [TestApp] TestApp $ scaffold setup
      ? No scaffold type was selected, use default (Metawidget & JSF)? [Y/n] y
      ? Scaffold provider [metawidget] is not installed. Install it? [Y/n] y
      ? Facet [forge.maven.WebResourceFacet] requires packaging type(s) [war], but is currently [jar]. Update packaging?
      plugins in your project.) [Y/n] y
      ...other output...
      *INFO** JSF2 and Metawidget currently require Partial State Saving to be disabled.

      It's great to see this info message. It relates to this bug in Mojarra (http://java.net/jira/browse/JAVASERVERFACES-1826). However the equivalent bug in MyFaces (https://issues.apache.org/jira/browse/MYFACES-2935) has been fixed for a while.

      Does SeamForge allow choosing Mojarra/MyFaces? If so, this info shouldn't appear for MyFaces. If not, could we just clarify it applies only to Mojarra? Perhaps by displaying the version number?

      *INFO** JSF2 (Mojarra 2.0.3) and Metawidget currently require Partial State Saving to be disabled.

      Thanks! In the meantime I'm pushing as hard as I can to get 1826 resolved!

      Richard.

      Attachments

        Activity

          People

            lincolnthree Lincoln Baxter III (Inactive)
            kennardconsulting Richard Kennard (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: