Uploaded image for project: 'Spring Boot & Cloud'
  1. Spring Boot & Cloud
  2. SB-379

Missing APR/native library in openshift image

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Out of Date
    • None
    • None
    • spring-boot
    • None

    Description

      The goal is to have working Tomcat instance with protocol HTTP/2. But HTTP/2 requires APR/native library which is not installed in the image.
      Affected image is "redhat-openjdk-18/openjdk18-openshift"
      The library is "libtcnative" in the package "tomcat-native". Required version of the library is at least 1.2.14.

      Attachments

        Activity

          People

            Unassigned Unassigned
            mocenas@redhat.com Martin Ocenas
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: