Uploaded image for project: 'Red Hat Process Automation Manager'
  1. Red Hat Process Automation Manager
  2. RHPAM-3480

Error logged if reusable subprocess has some dataInput mapping but no dataOutput mapping in stunner

    XMLWordPrintable

Details

    • CR1
    • Hide
      1. Import attached project in Business Central.
      2. Open main process and then click validate (check mark) button.

      Actual result

      Validation succeed without any error in GUI, but you can see the ERROR in server.log.

      Expected result

      Either both validation and server.log are free of errors, or there is also the message in GUI in case the server.log contains error messages.

      Show
      Import attached project in Business Central. Open main process and then click validate (check mark) button. Actual result Validation succeed without any error in GUI, but you can see the ERROR in server.log. Expected result Either both validation and server.log are free of errors, or there is also the message in GUI in case the server.log contains error messages.
    • 2021 Week 10-12 (from Mar 8), 2021 Week 28-30 (from Jul 12), 2021 Week 31-33 (from Aug 2), 2021 Week 34-36 (from Aug 23), 2021 Week 37-39 (from Sep 13), 2021 Week 40-42 (from Oct 4), 2021 Week 43-45 (from Oct 25), 2021 Week 46-48 (from Nov 15)
    • +

    Description

      When modelling a simple process, like Start->Reusable sub-process->End, and assign some process variable to Data input, validation would succeed but the following error appears in server.log.

       17:53:49,482 ERROR [org.drools.core.xml.ExtensibleXmlParser] (default task-39) Process Info: id:noDataOutputReproducer.main, pkg:com.gss.nodataoutputreproducer, name:main, version:1.0 
      Node Info: id: name: 
      Parser message: (null: 31, 31): cvc-complex-type.2.4.b: The content of element 'bpmn2:ioSpecification' is not complete. One of '{"http://www.omg.org/spec/BPMN/20100524/MODEL":inputSet, "http://www.omg.org/spec/BPMN/20100524/MODEL":outputSet}' is expected.

      Building project and running process works without any problem.

      Attachments

        Issue Links

          Activity

            People

              jenrique@redhat.com Jaime Enriquez
              rhn-support-hmiura Hiroko Miura
              Lubomir Terifaj Lubomir Terifaj
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: