Uploaded image for project: 'Red Hat Process Automation Manager'
  1. Red Hat Process Automation Manager
  2. RHPAM-1245

When the process variables are modified (adding/deleting I/O variables) the forms are not updated successfully

    Details

    • Type: Bug
    • Status: New (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 7.0.0.GA
    • Fix Version/s: None
    • Component/s: Form Modeler
    • Labels:
      None

      Description

      The simple use case is: you have a process with 4 variables (2 inputs and 2 outputs), click "Generate all Forms", build and deploy the project. If the user instantiates the process, the Form contains the 4 variables defined in the process.

      After that, go to the process, remove 2 variables which were created in the first version and add other 2 new variables. click "Generate all Forms", build and deploy the project. If the user instantiates the process, the Form contains the 6 variables: the 4 initial variables (even if the user deleted 2 of them) and the new 2.

      So, the form is able to add the new variables, but the deleted variables keep in the form after be removed.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                pere.fernandez Pere Fernandez Perez
                Reporter:
                mcivantos MarĂ­a Civantos
                Tester:
                Juraj Soltes
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: