Uploaded image for project: 'JBoss BRMS Platform'
  1. JBoss BRMS Platform
  2. RHBRMS-2649

jcr2vfs migration tool does not run with Java 6

    XMLWordPrintable

Details

    • ER2
    • ER3

    Description

      The jcr2vfs migration tool fails to export JCR repository with the following exception:

      java.lang.UnsupportedClassVersionError: org/apache/tika/parser/Parser : Unsupported major.minor version 51.0
      ...
      at
      org.drools.workbench.jcr2vfsmigration.jcrExport.CategoryExporter.export(CategoryExporter.java:59)
      12:53:27 at org.drools.workbench.jcr2vfsmigration.jcrExport.CategoryExporter.exportAll(CategoryExporter.java:49)
      12:53:27 at org.drools.workbench.jcr2vfsmigration.jcrExport.CategoryExporter$Proxy$$$_WeldClientProxy.exportAll(CategoryExporter$Proxy$$$_WeldClientProxy.java)
      12:53:27 at org.drools.workbench.jcr2vfsmigration.JcrExporter.exportAll(JcrExporter.java:81)
      12:53:27 at org.drools.workbench.jcr2vfsmigration.JcrExporterLauncher.launchExport(JcrExporterLauncher.java:56)
      12:53:27 at org.drools.workbench.jcr2vfsmigration.JcrExporterLauncher.run(JcrExporterLauncher.java:48)
      12:53:27 at org.drools.workbench.jcr2vfsmigration.JcrExporterLauncher.main(JcrExporterLauncher.java:33)

      It seems that the problem is caused by Tika library which has not been compiled for Java 6. There seems to be no upgrade in community BOMs, but the product uses a productized version of this library 1.3.0.redhat-1, so it might be an issue with the productized artifact only.

      This is a regression from 6.4.0 ER1.

      Attachments

        Activity

          People

            rzhang+1@redhat.com Cheng Zhang (Inactive)
            mwinkler@redhat.com Marek Winkler
            Marek Winkler Marek Winkler
            Marek Winkler Marek Winkler
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: