Uploaded image for project: 'RESTEasy'
  1. RESTEasy
  2. RESTEASY-1528

Servlet 2.x integration broken by RESTEASY-1477

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.1.0.Beta2
    • Fix Version/s: 3.1.0.CR2, 3.0.20.Final
    • Component/s: None
    • Labels:
      None

      Description

      By running the testsuite against a preliminary version of WildFly patched to include RESTEasy 3.1.0.CR1 (including jaxrs subsystem cleanup of references to API dropped in RESTEASY-1477), I noticed failures in tests that happen to still use resteasy.scan option and the Servlet 2.x container integration approach. So it looks like we should revert 1477 for now and properly drop the whole servlet 2.x support in the future (after having checked possible consequences on the spring and guice integration).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              asoldano Alessio Soldano
              Reporter:
              asoldano Alessio Soldano
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: