Uploaded image for project: 'Railo'
  1. Railo
  2. RAILO-2019

PostgreSQL doesn't work with jdbc-Drivers 8.4 and later

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.1.0.000, 3.3.5.002
    • Fix Version/s: None
    • Labels:

      Description

      The jdbc-drivers (8.x) delivered with railo version < 4 have been running normal. If you try to upgrade to the latest drivers 9.1 or even 9, you'll get errors for queries using the result-attribute. The error message looks like:
      ERROR: syntax error at or near "RETURNING" Position: 83

      This also happens with cfscript-style, in most cases even without using the result attribute.

      The problem becomes worse since railo >= 4 is shipped with actual releases of these drivers.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                micstriit Michael Offner
                Reporter:
                mischa.sameli Mischa Sameli
              • Votes:
                5 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: