Uploaded image for project: 'OpenShift Service Mesh'
  1. OpenShift Service Mesh
  2. OSSM-711

Deployconfig objects not returning all data

    XMLWordPrintable

Details

    • Bug
    • Status: New (View Workflow)
    • Major
    • Resolution: Unresolved
    • OSSM 2.0.8
    • None
    • Maistra
    • None
    • Compatibility/Configuration, User Experience

    Description

      DeploymentConfigs are now visible on the kiali screen after the mentioned change.

      However, according to the attached images, we click on workload and select the desired deploymentconfig, no data referring to it is collected:

      Traffic
      Graphic.
      Inbound Metrics
      Outbound Metrics.

      When we perform the same test by clicking on the applications screen, the data is displayed normally.

      I inform you that this error scenario is only when using deploymentconfig, when using deployments the graphics are displayed on both screens.

      Please let me know if you need a must-gather from the cluster

      Attachments

        1. alerts-engine-button-panic-v1.yml
          20 kB
        2. cm-kiali.yml
          8 kB
        3. deploymentconfig-issue.zip
          297 kB
        4. kiali.log
          2.33 MB
        5. screenshot-1.png
          screenshot-1.png
          314 kB
        6. screenshot-2.png
          screenshot-2.png
          150 kB
        7. screenshot-3.png
          screenshot-3.png
          93 kB

        Activity

          People

            Unassigned Unassigned
            rhn-support-mnunes Miguel Nunes
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated: