Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-12273

When Creating Sample Devfile from the Samples Page, Topology Icon is not set

    XMLWordPrintable

Details

    • Informational
    • ODC Sprint 236
    • 1
    • No
    • Rejected
    • False
    • Hide

      None

      Show
      None

    Description

      This is a clone of issue OCPBUGS-7485. The following is the description of the original issue:

      Description of problem:

      When Creating Sample Devfile from the Samples Page, corresponding Topology Icon for the app is not set. This issue is not observed when we create a BuildImage from the Samples page.

      Version-Release number of selected component (if applicable):

      4.13

      How reproducible:

      Always

      Steps to Reproduce:

      1. Create a Sample Devfile App from the Samples Page
      2. Go to the Topology Page and check the icon of the app created.
      

      Actual results:

      The generic Openshift logo is displayed

      Expected results:

      Need to show the corresponding app icon (Golang, Quarkus, etc.)

      Additional info:

      In case of creating sample of BuilderImage, the icon gets properly set as per the BuilderImage used.
      
      Current label: app.openshift.io/runtime=dotnet-basic
      Change to: app.openshift.io/runtime=dotnet

      Attachments

        Issue Links

          Activity

            People

              avik6028 Avik Kundu
              openshift-crt-jira-prow OpenShift Prow Bot
              Sanket Pathak Sanket Pathak
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: