Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-9646

Fuse 7.3: change OSGi import ranges to match Fuse 7.3/Undertow 2

    Details

    • Sprint:
      Keycloak Sprint 19
    • Story Points:
      1
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      Fuse 7.3 made an alignment with EAP 7.2 with respect to used servlet API and container.

      Fuse 7.3 supports:

      • servlet API 4.0
      • Undertow 2

      Thus all bundles that import io.undertow.* or javax.servlet.* packages should change the import range:

      • undertow: [1.4,3) (looks like it's already there)
      • servlet API: [3.1,5) (now it's [3.1,4.0))

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  grgrzybek Grzegorz Grzybek
                  Reporter:
                  grgrzybek Grzegorz Grzybek
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: