Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-9448

keycloak-server.war empty in domain cluster mode when setting bind address

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Explained
    • Affects Version/s: 4.8.3.Final
    • Fix Version/s: None
    • Component/s: Distribution
    • Labels:
      None
    • Steps to Reproduce:
      Hide
      1. Download Keycloak from https://downloads.jboss.org/keycloak/4.8.3.Final/keycloak-4.8.3.Final.zip and extract it
      2. Run a relevant domain.sh startup command such as:
        1. ./bin/domain.sh --host-config=host-master.xml -Djboss.bind.address.management=0.0.0.0 -Djboss.bind.address.private=192.168.2.143
      3. Verify that http://localhost:8080/auth returns a 404 error
      4. Verify that ./keycloak-4.8.3.Final/domain/servers/server-one/tmp/keycloak-server.war is an empty directory/file
      Show
      Download Keycloak from https://downloads.jboss.org/keycloak/4.8.3.Final/keycloak-4.8.3.Final.zip and extract it Run a relevant domain.sh startup command such as: ./bin/domain.sh --host-config=host-master.xml -Djboss.bind.address.management=0.0.0.0 -Djboss.bind.address.private=192.168.2.143 Verify that http://localhost:8080/auth returns a 404 error Verify that ./keycloak-4.8.3.Final/domain/servers/server-one/tmp/keycloak-server.war is an empty directory/file
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      When running in domain cluster mode, the moment I set the bind address (with -b or -Djboss.bind.address.private=) on startup, the resulting keycloak-server.war is empty - giving a to-be-expected 404 error when trying to use Keycloak.

      I have tried the reproduced steps on two Linux distros and get the same issue; I also did try some older versions of Keycloak and the issue was present there too.

      It might be that I simply shouldn't be setting the bind address, although I thought this was required for the replication of infinispan cache data via the multicast interface (as per the Clustering section of the documentation)?

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tristanperry Tristan Perry
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: