Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-8463

On realm import Service account roles are not assigned to clients

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Duplicate Issue
    • 4.5.0.Final
    • None
    • Import/Export
    • None
    • Hide
      1. Create new Role
      2. Create new client
        Make sure 'Service Accounts Enabled' is enabled
      3. Assign the client to the created role in the 'Service Accounts Roles' tab.
      4. Do an export of the realm
      5. Delete client and the role
      6. Do an import for the realm
      7. Verify that the role and client exist but the role it is not assigned to the client
      Show
      Create new Role Create new client Make sure 'Service Accounts Enabled' is enabled Assign the client to the created role in the 'Service Accounts Roles' tab. Do an export of the realm Delete client and the role Do an import for the realm Verify that the role and client exist but the role it is not assigned to the client
    • NEW
    • NEW

    Description

      When importing a realm using CLI file import the realm and roles are created correctly, but the roles are not assigned on the Service account roles tab.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              bech_jira Peer Bech Hansen (Inactive)
              Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: