Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-7737

Get rid of old aesh for keycloak-admin-cli and keycloak-client-registration-cli

    XMLWordPrintable

Details

    • Feature Request
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Deferred
    • None
    • None
    • None
    • NEW
    • NEW

    Description

      Upgrade of Keycloak distribution to use Wildfly 13 is done.

      However dependency on old aesh used in Wildfly 11 (org.jboss.aesh:aesh:0.66.19) is still needed as keycloak-admin-cli and keycloak-client-registration-cli are still using it.

      Fortunately old aesh is not needed among Wildfly modules. Both CLIs are packed in server distribution in directory KEYCLOAK_HOME/bin/client/ in the "fat" jars, which among other things, contain the classes of old aesh. But will be good to address this (EG. if there are security and other issues in old aesh, we won't be able to rely on Wildfly support etc)

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              mposolda@redhat.com Marek Posolda
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: