Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-331

NPE when using Wildfly Submodule on EAR

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.0-rc-1
    • Component/s: None
    • Labels:
      None
    • Steps to Reproduce:
      Hide

      1) Create EAR with embedded WAR
      2) Setup Wildfly to use Keycloak subsystem with name matching that of the ear
      3) Deploy the EAR file

      Show
      1) Create EAR with embedded WAR 2) Setup Wildfly to use Keycloak subsystem with name matching that of the ear 3) Deploy the EAR file

      Description

      I have an EAR (named bundle.ear) that contains a WAR. My secure-deployment is using the name "bundle.ear". During launch, I get the following NPE:

      Caused by: java.lang.NullPointerException
      	at org.keycloak.subsystem.extension.KeycloakAdapterConfigDeploymentProcessor.addJSONData(KeycloakAdapterConfigDeploymentProcessor.java:87)
      	at org.keycloak.subsystem.extension.KeycloakAdapterConfigDeploymentProcessor.addKeycloakAuthData(KeycloakAdapterConfigDeploymentProcessor.java:70)
      	at org.keycloak.subsystem.extension.KeycloakAdapterConfigDeploymentProcessor.deploy(KeycloakAdapterConfigDeploymentProcessor.java:60)
      	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:159) [wildfly-server-8.0.0.Final.jar:8.0.0.Final]
      	... 5 more
      

        Attachments

          Activity

            People

            Assignee:
            ssilvert Stan Silvert
            Reporter:
            mikesir87 Michael Irwin (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: