Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-18309

Client Initiated Account Linking - Missed Mapped Attributes

    XMLWordPrintable

Details

    • Bug
    • Status: Pull Request Sent
    • Minor
    • Resolution: Unresolved
    • 12.0.4
    • Backlog
    • OIDC

    Description

      Hi,

      we are developing an own react web application and integrate account linking functionality. We implemented a button and build a url to use the account linking functionality of keycloak.
      The created link is correct. The user have been linked correctly with external idp after clicking the button and submitting the external idp credentials.

      We configured multiple attribute mappers for the given idp. The mapper type is „Attribute Importer“, the sync mode override is „force“.

      The Problem: After correct linking to external idp, the relevant attributes are not mapped to user attributes.

      Only after login over the external idp, the attributes are correct mapped to user in keycloak.

      It seems that linking process does not trigger the syncronciation of configured attributes.

      Do I missed something?

      Sync mode of idp is „import“

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              andreas.simon Andreas Simon (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated: